<![CDATA[ Mehrsprachigen Website mit und ohne TLD - MODX Deutschland Forum]]> http://de.modx.com/forum/thread/?thread=7386 <![CDATA[Re: Mehrsprachigen Website mit und ohne TLD]]> http://de.modx.com/forum/thread/7386/mehrsprachigen-website-mit-und-ohne-tld#dis-post-39068 http://meineDomain.com/pt/contact.html
Allerdings leitet modx dann auf die 404 Seite

Hier mal ein paar Zeilen aus meinem Quellcode
<base href="http://meineDomain.com/" />
<a href="/pt/contact.html" title="Contact" >Contact</a>]]>
bergtroll 25.01.2018 15:13 http://de.modx.com/forum/thread/7386/mehrsprachigen-website-mit-und-ohne-tld#dis-post-39068
<![CDATA[Re: Mehrsprachigen Website mit und ohne TLD]]> http://de.modx.com/forum/thread/7386/mehrsprachigen-website-mit-und-ohne-tld#dis-post-39066 Jako 25.01.2018 12:28 http://de.modx.com/forum/thread/7386/mehrsprachigen-website-mit-und-ohne-tld#dis-post-39066 <![CDATA[Mehrsprachigen Website mit und ohne TLD]]> http://de.modx.com/forum/thread/7386/mehrsprachigen-website-mit-und-ohne-tld#dis-post-39065 ich habe folgendes Problem mit einer mehrsprachigen Website.
Für jede Sprache wurden Kontexte angelegt. Für die Sprachen deutsch, englisch und russisch sind TLD vorhanden. Soweit so gut.



Nun kommen aber Sprachen dazu, für die keine TLD zur Verfügung stehen.
Diese Domain soll dann z.B. „meineDomain.com/pt/contact“lauten.



Aktuell bekomme ich allerdings immer „meineDomain.com/ptcontact“ ausgegeben.


Ich vermute das der Fehler in den Kontext Settings oder der .htaccess Datei liegt.

Von beiden habe ich einen Screenshot in den Anhang gepackt.



Die Kontexte verwalte ich mit „Cross Contexts Settings 1.0.5-pl“

Das Routing übernimmt XRouting



Vorab schon einmal vielen Dank für Eure Mühe.

https://www.dropbox.com/s/301wq5yhmvr22ik/Bildschirmfoto%202018-01-25%20um%2009.54.59.jpg?dl=0
https://www.dropbox.com/s/q0u0eoavrimut0y/Bildschirmfoto%202018-01-25%20um%2010.06.12.png?dl=0

]]>
bergtroll 25.01.2018 11:27 http://de.modx.com/forum/thread/7386/mehrsprachigen-website-mit-und-ohne-tld#dis-post-39065